An editorial opinion

The use of the term save object... on the popup menu is not only confusing to students, it is probably technically incorrect.

It would have been better if the Alice developers at Carnegie had used the term save class... instead.

Why does it matter?

It matters because learning object-based programming is confusing enough for students when the terminology is correct.

The use of incorrect and confusing terminology just makes matters worse.